Lead Data Synchronization Issue

Incident Report for Storable CRM

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 12:09 EDT

Monitoring

A fix has been deployed, and we're observing system behavior to confirm stability.
Posted Aug 13, 2025 - 11:10 EDT

Investigating

We're aware of an issue preventing lead data from loading properly within Storable CRM. This issue impacts the following Facility Management Systems:

SiteLink:
-Leads are not syncing with CRM (new leads, cancellations, etc.)

SSM:
-Leads are not syncing with CRM (new leads, cancellations, etc.)
-Units not loading
-Promotions

Hummingbird:
-Leads are not syncing with CRM (new leads, cancellations, etc.)
-Units not loading
-Promotions

Our team is investigating, and we will provide updates as we learn more. We apologize for any inconvenience and appreciate your patience as we work toward a resolution.
Posted Aug 13, 2025 - 11:04 EDT
This incident affected: Storable CRM (Storable CRM V2) and Contact Center (Contact Center V2).