Delayed lead sync

Incident Report for Storable CRM

Resolved

The issue affecting lead syncing has been fully resolved. All data has been processed, the backlog is cleared, and syncing is running normally again. Thank you for your patience while we worked through this.
Posted Aug 19, 2025 - 09:34 EDT

Investigating

We’re investigating an issue causing delays with leads syncing from integrated software into CRM. This may result in a long delay before new leads appear. Our team is actively working to identify the root cause and implement a fix. We’ll provide updates here as more information becomes available. Thank you for your patience.
Posted Aug 18, 2025 - 16:56 EDT
This incident affected: Storable CRM (Storable CRM V2).