Auto Collection Issue

Incident Report for Storable CRM

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 19:48 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2025 - 08:19 EDT

Investigating

We're aware of an issue impacting emails, text messages, and auto-collection calls for collection events. Our team is working on a solution, and we will provide updates as we learn more. Thank you for your patience.
Posted Sep 25, 2025 - 15:05 EDT
This incident affected: Storable CRM (Storable CRM V2) and Collections (Collections V2).