Outage issue

Incident Report for Storable CRM

Resolved

This issue is resolved.
Posted Jun 12, 2025 - 17:07 CDT

Monitoring

We're aware of an outage impacting multiple CRM upstream vendors. Some CRM functions may be affected. Thanks for your patience as we monitor this situation. We will provide updates once we learn more.
Posted Jun 12, 2025 - 14:04 CDT
This incident affected: Storable CRM (Storable CRM V1, Storable CRM V2).