System Sync Issue

Incident Report for Storable CRM

Resolved

Everything had recovered as of 1am CST, so this matter is being marked as resolved.
Posted Dec 27, 2024 - 05:04 CST

Identified

We are currently seeing issues with data syncing between CallPotential/Storable CRM and the Facility Management Software. This has caused a backlog of data needing to be updated. We have identified the cause and are working towards resolving this as quickly as possible. At this time you will see delays in being able to access existing leads or when trying to create brand new leads.
Posted Dec 26, 2024 - 17:27 CST