We have released our dashboard update intended to correct the inaccurate agent and queue status information.
However, our telecommunications provider, Twilio, is currently experiencing issues with their event streams, which is preventing agent and queue statuses from remaining fully synchronized on the dashboard.
At this time, the issue remains limited to the display of status information and is not impacting call functionality. That said, we understand the importance of having accurate, real-time visibility into your call center activity and recognize the impact this may have on your business.
Our team is actively working with Twilio to better understand the issue and obtain an estimated time for resolution. We will provide another update as soon as we have additional information to share.
Thank you for your continued patience and understanding.
Posted Aug 28, 2026 - 13:21 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 28, 2026 - 12:00 EDT
Update
Our team is currently making adjustments to the dashboard and preparing an update to correct the inaccurate agent and queue status information.
The update is expected to be available shortly. Once it has been deployed, we will test the dashboard to confirm that agent and queue statuses are updating accurately and as expected.
We will provide another update once testing is complete and the issue has been confirmed as resolved.
Thank you for your continued patience and understanding.
Posted Aug 28, 2026 - 11:59 EDT
Investigating
We are currently investigating an issue causing the Call Center Agent Dashboard to display agent statuses with a delay.
At this time, the issue appears to be limited to the dashboard display and does not appear to impact call functionality. However, we understand that delayed status updates can make it difficult to accurately monitor call center activity.
Our team is actively working to identify the cause and resolve the issue as quickly as possible. We will provide another update as soon as additional information is available.
Thank you for your patience and understanding while we work to resolve this issue.
Posted Aug 28, 2026 - 09:36 EDT
This incident affects: Contact Center (Contact Center V2).