Call Center Connectivity Issues

Incident Report for Storable CRM

Resolved

This incident has been resolved.
Posted Jul 23, 2024 - 12:52 CDT

Monitoring

Twilio is stating that all function has been restored and calls should be flowing as expected again, we will continue monitoring for any abnormalities in the system.
Posted Jul 23, 2024 - 09:59 CDT

Investigating

Twilio is currently experiencing issues that are causing problems with agents being able to connect and accept calls. The issue can be followed here https://status.twilio.com/incidents/bnp8461qzjbs and we will be updating our status page as more information becomes available.
Posted Jul 23, 2024 - 08:57 CDT
This incident affected: Contact Center (Contact Center V1).