Email distribution issue

Incident Report for Storable CRM

Resolved

This incident has been resolved
Posted Apr 29, 2025 - 17:18 CDT

Monitoring

We've deployed a fix, and our team will continue to monitor performance and provide updates. We appreciate your patience as we resolve this issue.
Posted Apr 29, 2025 - 15:07 CDT

Identified

We're aware of an email distribution issue. Some operational email notifications are being distributed more widely instead of being sent to the intended recipients. We apologize for the inconvenience and will provide updates until this issue has been resolved.
Posted Apr 29, 2025 - 10:17 CDT
This incident affected: Storable CRM (Storable CRM V2), Contact Center (Contact Center V2), and Collections (Collections V2).