Inbound & Outbound Communication Outage

Incident Report for Storable CRM

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 13:24 CDT

Monitoring

Our communications provider has reported recovery, and our internal initial testing is also showing recovery. We will continue to monitor this issue.
Posted Mar 31, 2025 - 12:31 CDT

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 11:37 CDT

Investigating

Our communications provider has reported an outage which is impacting inbound and outbound call communications. We are actively monitoring for a resolution and will post updates as they are available.
Posted Mar 31, 2025 - 11:19 CDT
This incident affected: Contact Center (Contact Center V1, Contact Center V2) and Storable CRM (Storable CRM V1, Storable CRM V2).