Unable to make or receive calls

Incident Report for Storable CRM

Resolved

We are seeing that calls are working as expected, and this incident is resolved. If you experience any further issues, please reach out to our Support Team for further assistance.
Posted Jan 02, 2025 - 10:15 CST

Monitoring

We're seeing that calls are now able to be completed as expected. We are continuing to monitor the situation. If you experience any additional issues pertaining to call errors, please chat in with our Support team.
Posted Jan 02, 2025 - 09:54 CST

Investigating

We are currently investigating an issue where Call Center agents are unable to make or receive calls due to an audible "Application Error" message. We are actively working to resolve this instance as soon as possible.
Posted Jan 02, 2025 - 08:32 CST