Today's call recordings are temporarily unavailable

Incident Report for Storable CRM

Resolved

This issue has been resolved.
Posted Nov 25, 2025 - 14:36 EST

Identified

Our team has identified an issue that has temporarily made call recordings from November 24th unavailable in Storable CRM v1. A fix is scheduled for tonight, and we expect all recordings to be fully restored and accessible by tomorrow.

Thank you for your patience while we work to resolve this matter.
Posted Nov 24, 2025 - 13:34 EST
This incident affected: Storable CRM (Storable CRM V1).