Issue taking and making calls

Incident Report for Storable CRM

Resolved

The issue causing disruptions with agent connectivity and preventing calls from connecting properly to our system has been resolved.
Posted Jul 14, 2025 - 13:35 CDT

Update

We are continuing to investigate this issue.
Posted Jul 14, 2025 - 11:45 CDT

Investigating

Our telecommunications provider is currently experiencing widespread issues impacting multiple products. This is causing disruptions with agent connectivity and preventing calls from connecting properly to our system.

At this time, there is no available workaround. We are actively working with Twilio to monitor and resolve the situation. As soon as we have an update, we will share it here.

You can also follow the live incident updates directly at: https://status.twilio.com/incidents/sp8glbzt2mcv.
Thank you for your patience and understanding.
Posted Jul 14, 2025 - 11:41 CDT
This incident affected: Contact Center (Contact Center V1, Contact Center V2) and Storable CRM (Storable CRM V1, Storable CRM V2).