reCAPTCHA site key Error when accessing payment link

Incident Report for Storable CRM

Resolved

This incident has been resolved.
Posted Aug 22, 2024 - 17:05 CDT

Investigating

We are aware of the error that some tenants are seeing when accessing pay links not allowing them to submit a payment. We are trying to determine why this is occurring and have found that refreshing the browser a couple of times. We realize this is not an ideal solution, however for the time being it will allow your tenants to get their payment to go through.
Posted Aug 22, 2024 - 13:15 CDT