AWS & Twilio Outage

Incident Report for Storable CRM

Resolved

The issue has been fully resolved, and all impacted services have been restored. Our teams have verified normal operations and will continue monitoring to ensure continued stability. We sincerely appreciate your patience and understanding.
Posted Oct 21, 2025 - 10:10 EDT

Monitoring

We are currently monitoring an ongoing AWS service outage that is affecting Twilio, our communications provider. As a result, Storable CRM communication services, including phone calls, text messages, and emails, are experiencing disruptions. Additionally, our help site host is impacted, causing help articles to be temporarily unavailable.

Our team is in close contact with our communications provider and is actively tracking recovery progress. We appreciate your patience and will provide updates as more information becomes available.
Posted Oct 20, 2025 - 10:26 EDT
This incident affected: Contact Center (Contact Center V1, Contact Center V2), Storable CRM (Storable CRM V1, Storable CRM V2), Collections (Collections V1, Collections V2), and Twilio SMS.