Storable CRM Reports Issue

Incident Report for Storable CRM

Resolved

This issue has been resolved. Please note, impacted reporting data from June 11, 2025 will be available the morning of June 13, 2025.
Posted Jun 12, 2025 - 09:01 CDT

Investigating

We’re currently investigating an issue impacting V2 reports. Thank you for being so patient as we work to identify the cause. We will share updates as they become available.
Posted Jun 12, 2025 - 08:30 CDT
This incident affected: Storable CRM (Storable CRM V2).