Callers being disconnected when put on hold

Incident Report for Storable CRM

Resolved

This incident has been resolved.
Posted Aug 10, 2025 - 16:58 EDT

Monitoring

We have resolved the issue regarding calls being put on hold causing the call to disconnect and are monitoring for any outlying issues. If you are still experiencing any problems with the hold functionality please send an email to crmsupport@storable.com so we can investigate.
Posted Aug 09, 2025 - 16:11 EDT

Investigating

We are currently looking into an issue regarding callers being disconnected when and agent puts them on hold. At this time we recommend utilizing the Mute button instead of the Hold button. We are not seeing any issues around transfers, this is specific to putting someone on hold. As soon as we have additional information we will share it here.
Posted Aug 09, 2025 - 14:32 EDT
This incident affected: Contact Center (Contact Center V2).